Maintenance has been successfully completed. We thank you for your patience.
Posted Feb 15, 2026 - 10:17 CET
Verifying
Maintenance has been performed and we're verifying the results.
Posted Feb 15, 2026 - 10:13 CET
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 15, 2026 - 10:00 CET
Scheduled
We will be performing scheduled infrastructure maintenance on Sunday, 15th, between 10:00 and 11:00 CET. During this time, services in the Swedish region will be unavailable. We appreciate your patience while we complete this work.
Posted Feb 13, 2026 - 19:20 CET
This scheduled maintenance affected: Cosafe Mobile Application, Cosafe Web Application, Cosafe Admin Panel, Cosafe Desktop Application, and CoAlert.